p0300 mil light on and off. - Dodge Nitro Forum
Dodge Nitro Dodge Nitro
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   Dodge Nitro Forum > Dodge Nitro Discussion > Problems / Dealer Service

Problems / Dealer Service If you are having problems with your Dodge Nitro and want to discuss it, please do so in here. If you need to talk about service that you may need or have received from a dealership, please do so in here.

Dodge-Nitro.com is the premier Dodge Nitro Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03-26-2012, 05:14 PM
Junior Member
 
Join Date: Mar 2012
Posts: 9
p0300 mil light on and off.

so i just bought a 2010 dodge nitro shock edition all white(pics coming soon) and literally ten min after driving off the lot the engine light comes on. i plugged a scanner and got a p0300 for random misfire. i wasn't worried since im still under factory warranty. but the day i go to bring it in to service i start it up and the mil light goes away and drives fine, before i felt the misfire a lil bit coming off a complete stop. then a week goes by and the light comes on again, i plug up the scanner same code, now i dont erase it just turned off the car and unplugged scanner, start it up again and like magic this light is off. now this is really annoying as all i want to do is just take this car in to the dealer and not have them hit me with a diag fee since the light is not on and wondering if anyone has experienced this problem. imma mechanic and know how the dealers work so thats why i'm hoping this light could pop on soon and i can just tow it straight there so they can see i'm not crazy. but yeah if anyone has experinced this please help!!! lol by the way i'm new to this site i also have an 82 toyota supra and have a account on celica supra.com
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-26-2012, 08:07 PM
rickaren's Avatar
Super Moderator
 
Join Date: Nov 2006
Location: Indiana
Posts: 13,159
Welcome!

Just don't erase your code next time, but I would think it could be viewed in history, but maybe not. I did the same thing but they found other error codes that I didn't know were in there with my checker. Good Luck!
__________________
Rick

Nitro Year: 2007 (1 of 113,000 sold)
Nitro Model: R/T 4X4 Stone White
CAT-BACK Exhaust, CAI, Projector Head Lamps
Fully-Equipped w/all factory options
Reply With Quote
  #3 (permalink)  
Old 03-31-2012, 06:19 AM
dhh3's Avatar
Senior Member
 
Join Date: Apr 2011
Location: Fort Wayne, Indiana
Posts: 723
Welcome to the forum. I am sorry to see that you had to join under these circumstances.
As Rick said, when the light come on, bring it to the dealer, and when you get there, do not shut off the engine. Sometimes, these sytems seem to "self test" and erase the codes if the system thinks it is fixed. I have had this happen to me!
Good luck.

__________________
2011 Nitro Heat 4x4: Bright Silver Metallic, Dark Slate Gray; Customer Preferred Package 24C; Trailer Tow Group; Hood-to-Fender Stripes; Navus 2; Uconnect.
MODS: Sunroof; S/S Nerf Bars; Mopar CAI, Pedal Kit, Chrome Rear License Plate Brow, Chrome Exterior Package, Production Style Cross Bars, Deluxe Molded Splash Guards, Cargo Security Cover, Door Sills & 3.7L Emblem; Media Center 430; Kicker Speakers, Sub and Amps; Carbon Fiber Dash Kits; Heated Katzkin Leather.
Reply With Quote
  #4 (permalink)  
Old 04-18-2012, 05:57 PM
Junior Member
 
Join Date: Mar 2012
Posts: 9
ok so heres a lil update. sry i still dont have pics its probably because i still dont have my car and this problem is persisting. so got the light on brought it straight to the dealer as soon as it came on. they checked it, drove it, erased it, and said it was a past code which i responded that thats bs because this code is on now and has been coming on and off. i was told to bring it back when it comes on. light comes on three days later, bring it in, let me know the next day that all they found was one faulty spark plug and ran fuel injection cleaner thru it thinking maybe i got bad gas which is also bs because 5 min after purchasing the car it came on. they told me they drove it all day tried getting the light back on nothing that it was all good to go, i drive 20 min home light comes on as soon as i park it with it smoking this time. i go back to the dealer furious at this point and not once could they even get me a rental or loaner, since i work at a nissan dealer my manager was nice enough to let me use a 2012 maxima in the mean time which i might trade the truck in for. get a call from the dealer saying they contacted chrysler and they recommended a deep combustion cleaning which i never even heard of but what they had to do was remove the cylinder head of bank 2 and put this solvent in clean off everything and reinstall head. again no fix light comes on as soon as i leave the dealer!!! now its in the shop as i'm typing this and got a call yesterday morning that now chrysler recommends to replace that whole cylinder head!!! this is just rediculous. i told them from day one maybe you should try replacing all the coils, but no dodge is retarded and this is the solution they come up with. by the way this dealer is sherman dodge in skokie illinois i totally would rec to stay away from these a-holes! thru out all this everytime i had to find out something its because i had to call up there only twice did i get a call and that was to keep the car over night every other time i had to call not even a call to say my cars ready, i call and this guy nick c. in service is like " oh yea your car is ready and everythings fine" when obviously its not i'm now about to write to the service manager and say how rediculous this has become and a major let down that i'm not treated like a customer because of my age. i'm 25 and these guys are acting as if i'm a kid and this is not my car. just because of my looks i shouldnt be judge on that when i bring my personal car in for service.
Reply With Quote
  #5 (permalink)  
Old 04-19-2012, 04:23 AM
dhh3's Avatar
Senior Member
 
Join Date: Apr 2011
Location: Fort Wayne, Indiana
Posts: 723
I feel your pain. It sucks when you have to deal with a dealer like this. It's no wonder that dealers get a bad wrap when this stuff goes on. I remember that someone on the jeepcommander forum had issues with a dealer in your area. I guss I am one of the lucky ones with a dealer I can trust. Good luck in whatever you do. Age and sex should not matter in any business transaction, but that is the way this country runs!

__________________
2011 Nitro Heat 4x4: Bright Silver Metallic, Dark Slate Gray; Customer Preferred Package 24C; Trailer Tow Group; Hood-to-Fender Stripes; Navus 2; Uconnect.
MODS: Sunroof; S/S Nerf Bars; Mopar CAI, Pedal Kit, Chrome Rear License Plate Brow, Chrome Exterior Package, Production Style Cross Bars, Deluxe Molded Splash Guards, Cargo Security Cover, Door Sills & 3.7L Emblem; Media Center 430; Kicker Speakers, Sub and Amps; Carbon Fiber Dash Kits; Heated Katzkin Leather.
Reply With Quote
  #6 (permalink)  
Old 12-03-2012, 03:58 PM
Junior Member
 
Join Date: Dec 2012
Location: Panama City, Republic of Panama
Posts: 5
MIL light on-n-off

I have a 2008 Nitro R/T with the 4.0L engine. I had 40,000 miles of relatively problem free use (OK, the driver side front seat lower trim, with the power seat controls, keeps falling off) before I retired.
I moved out of the US to Panama City, Panama and within 3 months the MIL light started to come on. It would be there for a week, then it would clear by itself. A few days later it comes back; usually 15 seconds after a hot restart. I've talked to some other Chrysler/Dodge/Jeep owners who have the same experience.
I never took it to a dealer, the only Chrysler/Dodge/Jeep dealer is a dual with M-B; all the shop prices are the same - EXPENSIVE! Without access to any readout device, if you say this is a suspected misfire problem then I will ignore it as a poor fuel avaiability issue. Thanks for the information.
Reply With Quote
  #7 (permalink)  
Old 12-03-2012, 04:10 PM
dhh3's Avatar
Senior Member
 
Join Date: Apr 2011
Location: Fort Wayne, Indiana
Posts: 723
Quote:
Originally Posted by Art Buglione View Post
I have a 2008 Nitro R/T with the 4.0L engine. I had 40,000 miles of relatively problem free use (OK, the driver side front seat lower trim, with the power seat controls, keeps falling off) before I retired.
I moved out of the US to Panama City, Panama and within 3 months the MIL light started to come on. It would be there for a week, then it would clear by itself. A few days later it comes back; usually 15 seconds after a hot restart. I've talked to some other Chrysler/Dodge/Jeep owners who have the same experience.
I never took it to a dealer, the only Chrysler/Dodge/Jeep dealer is a dual with M-B; all the shop prices are the same - EXPENSIVE! Without access to any readout device, if you say this is a suspected misfire problem then I will ignore it as a poor fuel avaiability issue. Thanks for the information.

Welcome to the forum. What's it like to live in Panama?

__________________
2011 Nitro Heat 4x4: Bright Silver Metallic, Dark Slate Gray; Customer Preferred Package 24C; Trailer Tow Group; Hood-to-Fender Stripes; Navus 2; Uconnect.
MODS: Sunroof; S/S Nerf Bars; Mopar CAI, Pedal Kit, Chrome Rear License Plate Brow, Chrome Exterior Package, Production Style Cross Bars, Deluxe Molded Splash Guards, Cargo Security Cover, Door Sills & 3.7L Emblem; Media Center 430; Kicker Speakers, Sub and Amps; Carbon Fiber Dash Kits; Heated Katzkin Leather.
Reply With Quote
  #8 (permalink)  
Old 12-03-2012, 04:38 PM
Junior Member
 
Join Date: Dec 2012
Location: Panama City, Republic of Panama
Posts: 5
It's hot and HUMID - LOL. My wife is from Panama so she has no problem. Chrysler/Dodge/Jeep dealers down here are a joke! I brought my NITRO from the USA down here; about $600 to ship.
The roads down here leave a lot to be desired - they don't know how to build them, maintain them, or fix them when they break.
Reply With Quote
  #9 (permalink)  
Old 12-03-2012, 05:20 PM
dhh3's Avatar
Senior Member
 
Join Date: Apr 2011
Location: Fort Wayne, Indiana
Posts: 723
I went through the canal, after a sail completely around South America, when I was in the Navy - west to east. Maybe, one day I'll get to visit again!

__________________
2011 Nitro Heat 4x4: Bright Silver Metallic, Dark Slate Gray; Customer Preferred Package 24C; Trailer Tow Group; Hood-to-Fender Stripes; Navus 2; Uconnect.
MODS: Sunroof; S/S Nerf Bars; Mopar CAI, Pedal Kit, Chrome Rear License Plate Brow, Chrome Exterior Package, Production Style Cross Bars, Deluxe Molded Splash Guards, Cargo Security Cover, Door Sills & 3.7L Emblem; Media Center 430; Kicker Speakers, Sub and Amps; Carbon Fiber Dash Kits; Heated Katzkin Leather.
Reply With Quote
  #10 (permalink)  
Old 08-20-2013, 10:28 AM
Junior Member
 
Join Date: Aug 2013
Posts: 1
P0306 Misfire

I bough my wife's 2011 Nitro new from a local dealer. She just went over 42k miles. The check engine light came on a couple of days ago. While the light is on, the engine will spit and sputter like it's going to die. Then it goes back to running smooth. The running rough condition comes and goes.

I had the code checked and it was P0306. I was told that this indicated a misfire on cyc-6. I cleared the code. Put a highly recommended fuel injector cleaner in the tank and filled up with 92 octane fuel.

I bought NGK plugs that matched the factory plugs. When I removed the plug from cyc-6 it looked the same as all the others. No oil of fuel build up. As recommended in one of the posts that I saw, I swapped the coils from cyc-5 and cyc-6. I put it all back together. Engine ran smooth. No issues.

My wife drives 30 or 40 miles and the light is back on. Same code for cyc-6. While I had it apart, I looked at all the gaskets on the intake. They all looked good. No discoloration like you'd expect if there was a small leak.

Any thoughts?
Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Dodge Nitro Forum > Dodge Nitro Discussion > Problems / Dealer Service


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems engine light, ESP light, Throttle Light mcharnholm General Discussion 1 03-16-2011 11:55 PM
MIL light came on twice NO P codes? Frederick General Discussion 0 09-23-2009 06:27 AM
Engine Light On!!!!! CWFUNK General Discussion 8 03-13-2008 04:15 PM
Fog Light switch DodgeBrickHouse Chrysler/Dodge/Jeep News 1 12-04-2006 04:43 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 03:08 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.