Dodge Nitro Forum - View Single Post - Misfires on cyl 2,4,6 wth am i missing!?!?
View Single Post
post #8 of (permalink) Old 08-13-2019, 06:52 AM
nick
Junior Member
 
Join Date: Aug 2019
Posts: 2
Quote:
Originally Posted by trog623 View Post
Good Morning! ok here is my issue
2011 nitro heat with 4.0L had code P0300 in system.
This is what i have done so far and still getting misfire counts on cyl 2,4,6 only.

Replaced spark plugs
Performed compression test 225psi all cylinders but number 2 which was 220psi.
Smoke test for intake leaks, small leak at the egr tube. replaced gasket and retested ok.
switched coils side to side
switched injections side to side
switched o2 sensors side to side
Tested exhaust backpressure.ok.under 1 psi
checked engine timing,spot on.
check vacuum readings and they are steady at 19 and responds and should during a snap throttle test and driving test.
my adaptions values
short term 1/1 2.9% long term 1/1 8.6%
short term 2/1 1.0% long term 2/1 -4.4%
Had ecm anad tcm updated at dealer
ran tank of techron thru truck also.
I think i covered everything so far i'm baffled as to the cause short of removing the cylinder head and having it checked for cracks
I have a 2010 Caravan with same issue and have checked compression, cylinder leak down check, injector drop test, fuel pressure check, swapped coils plugs and injectors from one side to the other and the misfires are all on 2,4,6 no matter what I do??? Pulling my hair out, WTF
nick is offline  
 
 
For the best viewing experience please update your browser to Google Chrome