Introduction - Dodge Nitro Forum
New Member Introductions If you are a new member, please stop in here to introduce yourself, tell us about your ride, or ask questions about how to use the forum. If you have questions about the Nitro, please post them in the appropriate category

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-28-2007, 04:19 PM Thread Starter
Junior Member
 
Join Date: Oct 2007
Location: Woodbridge ON
Posts: 1
Introduction

Hi this is Wolfram (schlegelwolf) in Canada just outside (north) of Toronto Ontario.
I leased my Nitro SLT 4x4 in June 2007. Love it. 6000 miles later, no problem. However it sucks fuel way more then my Chevy Safari Van.

The Dealer, I bought it from does not seem to know much about the Nitro.
The Emergency ( Parking) Break does not hold. He does not know how to fix it.
I tried to have " U-Connect" as a after thought installed. It took the dealer 2 days before failure. These people just do not know.
Question I have: Can I install the U-Connect myself and upstart it with U-Connect? It cannot be brain surgery. How difficult is it to upstart?
The dealer said, It was installed sucsessfully, but failed to varify it.
Ontario will go handsfree probably next year.

thanks
schlegelwolf is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-28-2007, 11:04 PM
Member
 
David Louis Harter's Avatar
 
Join Date: May 2007
Location: Corning, CA
Posts: 59
Congratulations

Quote:
Originally Posted by schlegelwolf
I leased my Nitro SLT 4x4 in June 2007. Love it. 6000 miles later, no problem. However it sucks fuel way more then my Chevy Safari Van.
Congratulations on your purchase. I am not familiar with a Chevy Safari Van, but I would imagine your fuel economy should be near what you got with the van--assuming the van was similarly powered and equipped. I checked my mileage today, following a 60+mile journey to/from Chico (30 miles from here), and I got just over 22.5 MPG. In the city, I average 18.2 MPG. My city driving is not "big city" driving, however, in that I do not encounter stop lights during my daily commute to/from my office. I take secondary streets and encounter only one stop sign and no stop lights.

Quote:
The Emergency ( Parking) Break does not hold. He does not know how to fix it.
I have had no issues with my parking brake, but I would imagine that a simple adjustment would rectify your problem.

Quote:
I tried to have " U-Connect" as a after thought installed. It took the dealer 2 days before failure. These people just do not know.
Question I have: Can I install the U-Connect myself and upstart it with U-Connect? It cannot be brain surgery. How difficult is it to upstart?
The dealer said, It was installed sucsessfully, but failed to varify it.
Ontario will go handsfree probably next year.

thanks
If the dealer installed UConnect, it should be installed. I cannot imagine how it could be installed again if it has already been installed. It is possible that your dealer installed it but did not flash the computer that controlls it, thus not activating UConnect.

It sounds as though you need to find another dealer.
David Louis Harter is offline  
post #3 of 6 (permalink) Old 10-29-2007, 04:56 PM
Senior Member
 
Join Date: Apr 2007
Posts: 121
welcome to the forum!

btw, david did u get my pm?
corsairkid is offline  
 
post #4 of 6 (permalink) Old 10-29-2007, 05:21 PM
Member
 
David Louis Harter's Avatar
 
Join Date: May 2007
Location: Corning, CA
Posts: 59
Pm

Quote:
Originally Posted by corsairkid
welcome to the forum!

btw, david did u get my pm?
I am on my way right now!
David Louis Harter is offline  
post #5 of 6 (permalink) Old 10-29-2007, 07:04 PM
Junior Member
 
jabo77's Avatar
 
Join Date: Oct 2007
Posts: 9
First Cut IS the DEEPEST!!!!!

AHHHHH, we have all been here, getting the new Ride, being extra careful about where we park and all that!!! Well just over 2 weeks after picking up my baby...IT HAPPENED....was going down the road and I heard what I never want to hear....that "Clink" of a pebble hitting something somewhere on the car......a day or 2 of looking I couldnt find anything, it was when I was washing her I found it....I yelled out, "OH "F" ME"...right on the passenger side of the hood near that contour line a nice friggin deep chip in the paint.....DAMN I hate that feeling!!! Took her to an Alice in Chains and Black Crowes concert and she went unscathed...figures, just going to work it would happen!!! FYI....autozone carries the EXACT match, the past few days I have applied a drop or 2 with an UNdyed toothpick...gonna build it up, tape it off then hit it with 800...then 1000 and finally 2000 grit paper, then some good ole polishing compound, then buff it, thats all I think it will take.....Wish me luck kids!!!!!
jabo77 is offline  
post #6 of 6 (permalink) Old 10-29-2007, 09:09 PM
Senior Member
 
Join Date: Apr 2007
Posts: 121
Quote:
Originally Posted by jabo77
AHHHHH, we have all been here, getting the new Ride, being extra careful about where we park and all that!!! Well just over 2 weeks after picking up my baby...IT HAPPENED....was going down the road and I heard what I never want to hear....that "Clink" of a pebble hitting something somewhere on the car......a day or 2 of looking I couldnt find anything, it was when I was washing her I found it....I yelled out, "OH "F" ME"...right on the passenger side of the hood near that contour line a nice friggin deep chip in the paint.....DAMN I hate that feeling!!! Took her to an Alice in Chains and Black Crowes concert and she went unscathed...figures, just going to work it would happen!!! FYI....autozone carries the EXACT match, the past few days I have applied a drop or 2 with an UNdyed toothpick...gonna build it up, tape it off then hit it with 800...then 1000 and finally 2000 grit paper, then some good ole polishing compound, then buff it, thats all I think it will take.....Wish me luck kids!!!!!
good luck... as I am the only kid on this forum lol...well besides patrick.
corsairkid is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Nitro Forum > New User Introductions > New Member Introductions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Nitro Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Introduction SpoiledNitroWife New Member Introductions 0 04-19-2007 10:41 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome