ABS Speed Sensor - Dodge Nitro Forum
General Discussion This section contains general discussion relating to the Dodge Nitro - if it doesnt fit in a more specific section, use this.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-03-2013, 08:23 AM Thread Starter
Junior Member
 
Join Date: Apr 2013
Location: Wisconsin
Posts: 1
ABS Speed Sensor

My ABS, BAS/ESP, and traction control lights lit up on my dash. My scanner reads code c102b, which is Right rear speed sensor circuit. I have replaced the old sensor with a new Mopar sensor bought from my dealer. I have attempted to erase the code using my scanner, and it says it was successful. But the light stays on, and my cruise control is still disengaged. I have checked all the fuses, and don't seem to find any modules or relays that run the ABS. Do I need to test the connector for voltage or do I take it to the dealer and pay for them to use the fancy computer?

2007 Dodge Nitro, SLT
syotos is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-05-2013, 03:40 PM
Senior Member
 
dhh3's Avatar
 
Join Date: Apr 2011
Location: Fort Wayne, Indiana
Posts: 719
Welcome to the forum. I am sorry to see that you have joined under these circumstances.

Try this first: disconnect the negative terminal of your battery, and wait about 10 minutes. This will purge the memory, and reset the computer: like, restarting your computer at home.

If the lights remain on, or come back on, make sure that the connector to the wheel sensor is on correctly and tight. Also, check the connector's terminals. It could be a faulty connector/bent pins/corrosion, etc. Good luck, and let us know how you make out.






2011 Nitro Heat 4x4: Bright Silver Metallic, Dark Slate Gray; Customer Preferred Package 24C; Trailer Tow Group; Hood-to-Fender Stripes; Navus 2; Uconnect.
MODS: Sunroof; S/S Nerf Bars; Mopar CAI, Pedal Kit, Chrome Rear License Plate Brow, Chrome Exterior Package, Production Style Cross Bars, Deluxe Molded Splash Guards, Cargo Security Cover, Door Sills & 3.7L Emblem; Media Center 430; Kicker Speakers, Sub and Amps; Carbon Fiber Dash Kits; Heated Katzkin Leather.
dhh3 is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Nitro Forum > Dodge Nitro Discussion > General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Nitro Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
reversing sensor problems oz-nitro General Discussion 5 05-15-2015 05:22 AM
High Speed/Low Speed Bus dhh3 Audio/ Video/ Navigation / Electronics Discussion 4 06-07-2011 08:16 PM
problem with oxegyn sensor Mazin Ghazi Al-Nakshbandi General Discussion 2 09-15-2009 10:07 PM
Nitro 3.7L max speed? Street_Dancer General Discussion 4 03-06-2007 02:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome