Sometimes I lost porwer steering - Dodge Nitro Forum
General Discussion This section contains general discussion relating to the Dodge Nitro - if it doesnt fit in a more specific section, use this.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-08-2011, 01:01 PM Thread Starter
Junior Member
 
Join Date: Sep 2009
Posts: 23
Sometimes I lost porwer steering

I have a 2008 Diesel Nitro, european version. Now it has 73.000km and about 22 months. I love it.

From this summer, when I road some kilometers over 150 km/h (100 miles/hour) after some minutes I lost power steering: When I left the higway I have to made an special esfort to turn. Around 60 km/h (40m/h) suddenly power steering back. At sunny and hot days, I need less speed and time for the same problem.
Fluid is on right level and seems clean.

Any help?

Lombar

Jose Lombardia
Dodge Nitro CRD ‘Black Edition’ 2010
SPAIN
Lombar is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-08-2011, 03:53 PM
Senior Member
 
dhh3's Avatar
 
Join Date: Apr 2011
Location: Fort Wayne, Indiana
Posts: 719
I see that you posted this on both forums! Check the tension on the belt. Also, if the fluid is dirty, particles can block the orifices in your rack and pinion steering, causing it not to work. Good luck.






2011 Nitro Heat 4x4: Bright Silver Metallic, Dark Slate Gray; Customer Preferred Package 24C; Trailer Tow Group; Hood-to-Fender Stripes; Navus 2; Uconnect.
MODS: Sunroof; S/S Nerf Bars; Mopar CAI, Pedal Kit, Chrome Rear License Plate Brow, Chrome Exterior Package, Production Style Cross Bars, Deluxe Molded Splash Guards, Cargo Security Cover, Door Sills & 3.7L Emblem; Media Center 430; Kicker Speakers, Sub and Amps; Carbon Fiber Dash Kits; Heated Katzkin Leather.
dhh3 is offline  
post #3 of 5 (permalink) Old 10-09-2011, 02:45 AM Thread Starter
Junior Member
 
Join Date: Sep 2009
Posts: 23
Quote:
Originally Posted by dhh3 View Post
I see that you posted this on both forums!
Yes, many people only read one of them.

Quote:
Originally Posted by dhh3 View Post
Check the tension on the belt. Also, if the fluid is dirty, particles can block the orifices in your rack and pinion steering, causing it not to work.
Tension blet is working fine and fluid seems clean. I think is a hot problem. Whe I drive at high speed motor is running at high revs, so drive pump is running quick. And after some minutes I lost steering power. If i brake and reduce my speed about 40 miles/hour I contnue without it, but if I turn steering wheel suddenly I recover power steering.
About ten days I 'll go to official service, the next one it's about 500 km of home, my car it's on warranty until next december 6th, but I don´t like to stay some days living on a hotel waiting than solve my problem.

thanks

Lombar

Jose Lombardia
Dodge Nitro CRD ‘Black Edition’ 2010
SPAIN
Lombar is offline  
 
post #4 of 5 (permalink) Old 10-09-2011, 08:45 AM
Senior Member
 
dhh3's Avatar
 
Join Date: Apr 2011
Location: Fort Wayne, Indiana
Posts: 719
Quote:
Originally Posted by Lombar View Post
Whe I drive at high speed motor is running at high revs, so drive pump is running quick. And after some minutes I lost steering power. If i brake and reduce my speed about 40 miles/hour I contnue without it, but if I turn steering wheel suddenly I recover power steering.
thanks
The orifices (holes) in this system are very small. A tiny bit of crud (aluminum from inside the system, etc.) can block these, causing you to lose power. A sudden movement of the steering wheel can cause enough pressure to build up and cause the particle to dislodge and give you back your power. Just a thought. Let me know what your dealer says.






2011 Nitro Heat 4x4: Bright Silver Metallic, Dark Slate Gray; Customer Preferred Package 24C; Trailer Tow Group; Hood-to-Fender Stripes; Navus 2; Uconnect.
MODS: Sunroof; S/S Nerf Bars; Mopar CAI, Pedal Kit, Chrome Rear License Plate Brow, Chrome Exterior Package, Production Style Cross Bars, Deluxe Molded Splash Guards, Cargo Security Cover, Door Sills & 3.7L Emblem; Media Center 430; Kicker Speakers, Sub and Amps; Carbon Fiber Dash Kits; Heated Katzkin Leather.
dhh3 is offline  
post #5 of 5 (permalink) Old 11-14-2011, 09:37 AM Thread Starter
Junior Member
 
Join Date: Sep 2009
Posts: 23
Suddenly the winter arrived. So now the problem is off. My car fault only on hot days, so I have to wait summer times.
Whiletime dealer changed fluid without cost. They tryed to warm fluid and pump, stay the car running on paint oven, tested on highway at high revs, but now it's working fine.

Lombar

Jose Lombardia
Dodge Nitro CRD ‘Black Edition’ 2010
SPAIN
Lombar is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Nitro Forum > Dodge Nitro Discussion > General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Nitro Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Steering is binding while turning sounds General Discussion 3 02-24-2011 12:58 AM
tire squeal/ power steering noise whendrix1 Chrysler/Dodge/Jeep News 2 09-23-2010 07:05 AM
GM sues steering column supplier rickaren Chrysler/Dodge/Jeep News 0 11-24-2009 02:02 PM
GM to sell steering firm rickaren Chrysler/Dodge/Jeep News 0 10-08-2009 11:02 AM
Steering Wheel Lock phazer Chrysler/Dodge/Jeep News 6 11-26-2006 07:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome