Dodge Nitro Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I'VE HAD MY NITRO 2 DAYS!!!!!!!!! AND OUT 135 MILES ON IT OND THE ENGINE LIGHT IS ON ANYBODY ELSE HAVE THIS HAPPEN? I HAVE AN APPOINTMENT SAT. WITH THE DEALER.:mad: :mad:
 

·
Registered
Joined
·
6 Posts
Engine light

I had 3K on mine and the engine light came on, but after a couple of starts it went out and never came back on. The owners manual has something about just that.

Wayne
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Engine Light

Just Got Back From Dealer. He Said It Was A Gas Stem Valve That Was Stuck. Said They Fixed It And Reset Engine Light. (at218 Miles)
 

·
Registered
Joined
·
6 Posts
Engine light

That is so typical. You spend your time and money going back and forth to the dealer. They tap it, the light goes out. They tell you something, and send you on you way. Maybe this time they should change the part that stuck.

Wayne
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Well It's Back In The Shop. They Gave Me A Caliber To Drive. Lets See What Happens This Time.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Well It's Tuesday I Got My Truck Back I Guess I'll See If That
Damn Light Comes Back On.
 

·
Registered
Joined
·
1 Posts
Engine Light

My 2007 Nitro engine light came on at 900 miles in January '07. They reset it and found that a recall in a memory reprogram G40 did not "hold" in the memory flash. No discussion as to the engine light itself having a problem so I am taking that as a message that the light works fine.
The light came on today at about 1450 miles and is remaining on as before. No flashing. Back to the dealer this week sometime.
 

·
Registered
Joined
·
1 Posts
my wife and I just had our nitro R/T in the shop for the fourth time for the engine light. The code that keeps coming up on the scanner is for the intake runner valve. It seems to not work once in a wile. They have replaced the servo and a wiring harness supposidely and it still pulls the same code usually a week or so later after daily driving. They said this time they are going to put in a new PCU. we'll see i guess. I have noticed the studdering only once, at about 40mph. I also agree that the gas pedel feels abit weird. It feels like theres nothing there then its at half throttle. other then all this mess i do like it.
 
1 - 9 of 9 Posts
Top