Dodge Nitro Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am new here and hoping you all can help. Every google search on this topic points me to here.

I own a 2011 nitro heat that came with the factory RES CD player. I recently purchased a working RHB unit high speed BUS from eBay. I double checked the part numbers with Chrysler P05091184AC before purchasing and they said it was listed as compatible. Today I took the nitro in and had the option programmed to my vin. Plugged in the unit and nothing.

This is the condensed version of my crappy day. I know the unit works because I tried it in my girlfriends 2011 avenger and it powers on. I see members mentioning software updates for the RHB model so what am I missing? My nitro only has the C2 radio connector, antenna and Sirius antenna connectors in the dash. My dealership is clueless and tried running me in circles after charging me $125 to tell me it still won't work.

They then tried to say it was an "aftermarket unit" and not a dealer upgrade. This was after they said the part number was correct and should work plug n play with no programming. Now they're telling me to bring it back to service so they can run more tests and possibly replace the body control module because they think it's bad.

The nitro has 33K miles on it and is bone stock one owner. I'm hoping someone can tell me how to make this thing work. I'm leaning towards an issue with the can bus as I have read this is how the vehicle tells the radio to power on. Any and all info is appreciated sorry for the long rant.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
I just read that the RHB unit is designed for vehicles with uconnect? My girls car had the harness but not the mic and module. Is there any chance this is why the unit will not power on?
 
1 - 2 of 2 Posts
Top