Dodge Nitro Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Recently we have done work on a Nitro and we have ran into an issue. We had the battery disconnected for about a week while we were installing air suspension.

Now once we re-connected everything after we were done on the car and the lights start to pulse bright and then dim over and over. If you turn the ignition to the first click they come on and don't pulse and also when you unlock the car they work normal but as soon as you click it to the "on" position with the car running and off it starts. Also the blinker's, winshield wipers and the head light control's don't work. But the windows, horn, AC radio ect work normal. Any ideas??
 

·
Registered
Joined
·
162 Posts
Idea, Yes!!!

IF IT WERE MY VEHICLE AND THE BASIC WARRANTY STILL EXISTS, THEN THE NEXT PIT STOP WOULD BE THE DODGE MECHANIC SHOP! YOU NEVER KNOW, THERE MAY BE A FOURTH RECALL OUT THERE AND YOU ARE THE FIRST OF ITS KIND! DID YOU ADJUST ANY ELECTRICAL WIRING? PULL ANY FUSES? ADD ANY MODIFICATIONS TO THE PEFORMANCE OF THE ENGINE? OTHER THAN THIS, I AM CLUELESS, SORRY. BUT GOOD LUCK TO YOU!!

ON A FUNNY NOTE, LIKE I SAID, A FUNNY NOTE....THAT NITRO MAY BE RESPONDING FOR BEING "UNPLUGGED" FOR OVER A WEEK AND NOT BEING ABLE TO ENJOY THE LIFE OF THE RUMBLING IN THE CONCRETE JUNGLE OR EXPLORING THE TUNNELS OF LIFE OR I THINK I'D BETTER GO NOW, I DON'T KNOW THE RATING ON THIS SITE. LET US KNOW IF YOU GET THE CORRECT ANSWER. LOOKING FORWARD TO IT.

MCNABB IN LOUISIANA...........:cool:
 
1 - 2 of 2 Posts
Top