Dodge Nitro Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Good afternoon, I hope this finds you all well and staying cool this blistering summer.

We have a 2010 Nitro with 42,000 miles. Traction control, ABS, ESP/BAS, and engine light all came on with a sudden loss of power. Driving at 50mph on a clear day, fairly straight but curves in the road.

After we stopped on the shoulder, everything was still illuminated and power returned. Made it home, unpacked and the next morning when I went out to look things over, all the lights were off. Went up the road less than 1 mile and it happened again. Almost walked home it was so bad with the lack of power.

Any help would be greatly appreciated
 

·
Super Moderator
Joined
·
23,347 Posts
Welcome RMS Dryrocker

Could be several issues. You need to eliminate any battery problems first, while you are at it re-set the Nitro computer by disconnecting the battery cable for a few minutes. Simple stuff. Nitro have issues if the battery is older that 3 years in many cases.

LINK

Dodge Nitro :Battery issues?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Rickaren

Ok. Thanks. I disconnected the battery for 10 min. Went down the road several miles and one by one they all came back on including the engine light. Stopped on the road and restarted the vehicle to find the lights back on but the engine light off. Made it home with no trouble.
 

·
Super Moderator
Joined
·
23,347 Posts
Ok. Thanks. I disconnected the battery for 10 min. Went down the road several miles and one by one they all came back on including the engine light. Stopped on the road and restarted the vehicle to find the lights back on but the engine light off. Made it home with no trouble.
Great News!

Thanks for your reply.
 
1 - 4 of 4 Posts
Top