Dodge Nitro Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey everybody,

i recently bought a nitro 2011 SXT, I'm happy with the car :)
i have some small concerns that i noticed but I'm not sure its the car or I'm just suspicious

i hope you don't mind my explaining method but I'll try to explain it in best
1- while driving in the city i sometimes feel the car not going smooth with me as if I'm pushing on it hard while I'm not and the rpm is at 2000 as u know its still a new car and the dealer told me to go smooth on the car for the first 1000 km
2- i noticed it twice on a highway suddenly i feel the car speed stalls and the rpm goes down although my foot was not removed or even moved from the acceleration pedal.

i have a friend who bought the same car with me and he didn't notice any of this thing in his car that's what made me think I'm suspicious.

again i hope you don't mind my way in expressing my point and its good to find a place to share the thoughts and problems with the car
 

·
Super Moderator
Joined
·
23,454 Posts
Welcome Samanody! Good Luck with your new vehicle. It's brand new so give it some time.
 

·
Premium Member
Joined
·
712 Posts
Welcome to the forum. Since the SXT is no longer available in the States, you must be overseas. What engine/transmission combination do you have?

:cool:
 

·
Registered
Joined
·
12 Posts
if u have the sxt diesel combined with auto box they seem to take a bit of running in.dont know if remapping ecu is available in saudi but here in the uk we have remapped our diesel sxt and what a big difference to its driveability.insread of 174bhp we get 225 and alot better throttle response and torque.its alot smmother to drive.
 

·
Registered
Joined
·
64 Posts
Hello to you also from Germany.

There have been some Issues in the first Model Years.

Solution depends on your Answers to some little Questions:
Are you riding a Diesel?
Do you have automatic (how much Speeds) or Manual Shift?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
hey guys thnx for all the greetings

my car is 3.7L and its Automatic transmission with 4 speed and no i'm not riding diesel
 

·
Premium Member
Joined
·
712 Posts
hey guys thnx for all the greetings

my car is 3.7L and its Automatic transmission with 4 speed and no i'm not riding diesel
Your car has an electronic throttle cable (drive by wire). There is a sensor on the accelerator pedal. Possibly, there is a loose connection. I would take it into your dealer to have them check this out. It could be dangerous. BTW, you have a beautiful country.

:cool:
 
1 - 9 of 9 Posts
Top